keyboard_arrow_up

GoECart: No Heartbleed Vulnerability

GoECart is proud to report that GoECart servers are not … and have not … been susceptible to the recent “Heartbleed” vulnerability which have impacted numerous servers globally; GoECart SSL Certificates comply with best practices and are not exposed to this vulnerability.

GeoTrust, one of GoECart’s SSL certificate providers, issued a statement confirming this, stating “To be clear, this [Heartbleed] is a vulnerability of the OpenSSL library, and not a flaw with SSL/TLS nor certificates issued by GeoTrust. At no time were GeoTrust’s SSL or Code-Signing roots and intermediates at risk, nor was there ever an issue with GeoTrust certificates.”


Manish Chowdhary, Founder and CEO of GoECart, noted “Technically speaking, GoECart supports only Verisign and GeoTrust SSL certificates, encrypted with a 2048 key using SChannel implementation of the Transport Layer Security (TLS) protocol. In other words, our SSL Certificates comply with best practices and are not exposed to this vulnerability.”

Please contact GoECart directly with any questions concerns regarding this issue.